ubuntuでruby1.9.1にヴァージョンアップできた。

わかってみれば簡単だが、ハマってる時は全然見えない。
sudo gem1.9.1 install rubysdl
こういうことだ。
gem1.9.1とコマンドを打たなきゃならなかったのだ。
ruby1.9にすると
require "rubygems" がいらないんだね。
これで、スッキリする。
ヴァージョンアップの流れは、こうだ。

sudo apt-get install ruby1.9
sudo apt-get install libsdl-dev
sudo gem1.9.1 install rubysdl
sudo apt-get install imagemagick
sudo apt-get install libmagick9-dev
sudo gem1.9.1 install rmagick
sudo apt-get install libcairo2-dev
sudo gem1.9.1 install cairo

sudo ln -f /usr/bin/ruby1.9.1 /usr/bin/ruby
sudo ln -f /usr/bin/irb1.9.1 /usr/bin/irb
sudo ln -f /usr/bin/gem1.9.1 /usr/bin/gem
[PR]
by gaziya | 2011-05-28 14:46