ちょっと、整理

ubuntu11.04がでた。
これを機にruby1.9に乗り換えよう思う。
それと、rubygemsの依存をやめようと思う。

この、ブログに載せたものに関してのインストールメモ

sudo apt-get install ruby1.9
sudo apt-get install libsdl-ruby
sudo apt-get install libcairo-ruby
sudo apt-get install libffi-ruby
sudo apt-get install libtcltk-ruby
sudo apt-get install librsvg2-ruby
sudo apt-get install libgdk-pixbuf2-ruby
sudo apt-get install libgtk2-ruby
sudo apt-get install libpango1-ruby

sudo apt-get install imagemagick
sudo apt-get install r-base-core
sudo apt-get install graphviz
sudo apt-get install gnuplot-nox gnuplot-x11
sudo apt-get install mimetex
sudo apt-get install flydraw
sudo apt-get install potrace
sudo apt-get install xclip

wiiについてのインストール
sudo apt-get install libbluetooth-dev
sudo apt-get install git
sudo apt-get install automake
sudo apt-get install flex
sudo apt-get install bison
sudo apt-get install libgtk2.0-dev
sudo apt-get install python-dev
git clone https://github.com/abstrakraft/cwiid.git
cd ./cwiid
aclocal
autoconf
./configure
make
sudo make install

この時 /usr/local/libにlibcwiid.soはできる。

最後に
sudo ln -f /usr/bin/ruby1.9.1 /usr/bin/ruby
これは、お薦めはしません。
あくまでも、僕のメモです。
<追記>
上記のインストール状況で過去のプログラムを動かしたら、
エラーが、でちゃいました。
エラーを追っかけるのは面倒なので、
sudo ln -f /usr/bin/ruby1.8 /usr/bin/ruby
で、もとに戻しました。
そのうち、調べるかも?
[PR]
by gaziya | 2011-04-29 11:32